xsdlib-20090415.ebuild 1.1 KB

1234567891011121314151617181920212223242526272829303132333435363738394041424344454647484950515253
  1. # Copyright 1999-2017 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI="4"
  4. JAVA_PKG_IUSE="doc source"
  5. inherit java-pkg-2 java-pkg-simple
  6. DESCRIPTION="Sun XML Datatypes Library"
  7. HOMEPAGE="http://msv.java.net/"
  8. SRC_URI="http://java.net/downloads/msv/releases/${PN}.${PV}.zip"
  9. LICENSE="BSD Apache-1.1"
  10. SLOT="0"
  11. KEYWORDS="amd64 ~arm ppc64 x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~x64-solaris ~x86-solaris"
  12. IUSE=""
  13. COMMON_DEP="
  14. dev-java/xerces:2
  15. dev-java/relaxng-datatype:0"
  16. RDEPEND="${COMMON_DEP}
  17. >=virtual/jre-1.4"
  18. DEPEND="${COMMON_DEP}
  19. >=virtual/jdk-1.4
  20. app-arch/unzip"
  21. S="${WORKDIR}/${P}"
  22. java_prepare() {
  23. find -name '*.jar' -exec rm -v {} + || die
  24. }
  25. JAVA_SRC_DIR="src src-apache"
  26. JAVA_GENTOO_CLASSPATH="relaxng-datatype,xerces-2"
  27. src_compile() {
  28. java-pkg-simple_src_compile
  29. local dir; for dir in ${JAVA_SRC_DIR}; do
  30. pushd ${dir} > /dev/null || die
  31. jar -uf "${S}"/${PN}.jar $(find -name '*.properties') || die
  32. popd > /dev/null
  33. done
  34. }
  35. src_install() {
  36. java-pkg-simple_src_install
  37. dodoc README.txt
  38. dohtml HowToUse.html
  39. }