xstream-1.4.8-r1.ebuild 1.2 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657
  1. # Copyright 1999-2016 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=5
  4. JAVA_PKG_IUSE="doc source"
  5. inherit java-pkg-2 java-pkg-simple
  6. DESCRIPTION="A text-processing Java API that serialize objects to XML and back again"
  7. HOMEPAGE="http://x-stream.github.io"
  8. SRC_URI="http://central.maven.org/maven2/com/thoughtworks/${PN}/${PN}/${PV}/${P}-sources.jar"
  9. LICENSE="BSD"
  10. SLOT="0"
  11. KEYWORDS="amd64 ppc64 x86"
  12. CDEPEND="
  13. dev-java/kxml:2
  14. dev-java/xom:0
  15. dev-java/xpp3:0
  16. dev-java/cglib:3
  17. dev-java/dom4j:1
  18. dev-java/jdom:2
  19. dev-java/jdom:1.0
  20. dev-java/joda-time:0
  21. dev-java/jettison:0"
  22. # This package does need Java 8. See bug 564616.
  23. RDEPEND="
  24. ${CDEPEND}
  25. >=virtual/jre-1.8"
  26. DEPEND="
  27. ${CDEPEND}
  28. >=virtual/jdk-1.8
  29. app-arch/unzip"
  30. JAVA_GENTOO_CLASSPATH="
  31. xpp3
  32. xom
  33. kxml-2
  34. jdom-2
  35. jdom-1.0
  36. dom4j-1
  37. cglib-3
  38. jettison
  39. joda-time"
  40. # Two drivers for two very old implementations of StAX.
  41. # StAX has been last-rited from Gentoo as it is now part of the Java 6 JDK.
  42. # See bug 561504. These drivers rely on ancient APIs that aren't maintained
  43. # upstream and may contain security holes.
  44. JAVA_RM_FILES=(
  45. com/thoughtworks/xstream/io/xml/WstxDriver.java
  46. com/thoughtworks/xstream/io/xml/BEAStaxDriver.java
  47. )