cfortran-4.4-r3.ebuild 1.1 KB

1234567891011121314151617181920212223242526272829303132333435363738394041424344454647484950
  1. # Copyright 1999-2013 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=5
  4. inherit eutils
  5. DEB_PR="14"
  6. DESCRIPTION="Header file allowing to call Fortran routines from C and C++"
  7. HOMEPAGE="http://www-zeus.desy.de/~burow/cfortran/"
  8. SRC_URI="
  9. mirror://debian/pool/main/c/${PN}/${PN}_${PV}.orig.tar.gz
  10. mirror://debian/pool/main/c/${PN}/${PN}_${PV}-${DEB_PR}.diff.gz"
  11. SLOT="0"
  12. LICENSE="LGPL-2"
  13. KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux ~x86-macos"
  14. IUSE="examples"
  15. src_unpack() {
  16. default
  17. if use examples; then
  18. tar xvzf "${S}"/cfortran.examples.tar.gz || die
  19. mv eg examples || die
  20. ln -sfn sz1.c examples/sz1/sz1.C || die
  21. ln -sfn pz.c examples/pz/pz.C || die
  22. fi
  23. }
  24. src_prepare() {
  25. epatch "${WORKDIR}"/${PN}_${PV}-${DEB_PR}.diff
  26. }
  27. src_install() {
  28. insinto /usr/include/cfortran
  29. doins cfortran.h
  30. dosym cfortran/cfortran.h /usr/include/cfortran.h
  31. dodoc cfortran.doc debian/{NEWS,changelog,copyright}
  32. dohtml cfortran.html index.htm cfortest.c cfortex.f
  33. if use examples; then
  34. insinto /usr/share/${PN}
  35. doins -r "${WORKDIR}"/examples
  36. fi
  37. }