closure-compiler-bin-20170218.ebuild 648 B

123456789101112131415161718192021222324252627282930
  1. # Copyright 1999-2017 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI="5"
  4. inherit java-pkg-2
  5. DESCRIPTION="JavaScript optimizing compiler"
  6. HOMEPAGE="https://github.com/google/closure-compiler"
  7. SRC_URI="https://dl.google.com/closure-compiler/compiler-${PV}.tar.gz -> ${P}.tar.gz"
  8. LICENSE="Apache-2.0"
  9. SLOT="0"
  10. KEYWORDS="~amd64 ~x86"
  11. IUSE=""
  12. RDEPEND=">=virtual/jre-1.6"
  13. S=${WORKDIR}
  14. src_install() {
  15. java-pkg_jarinto /opt/${PN}-${SLOT}/lib
  16. java-pkg_newjar ${PN%-bin}-v${PV}.jar ${PN}.jar
  17. java-pkg_dolauncher \
  18. ${PN%-bin} \
  19. --jar /opt/${PN}-${SLOT}/lib/${PN}.jar \
  20. -into /opt
  21. dodoc README.md
  22. }