epic-0.9.3.3-r1.ebuild 975 B

12345678910111213141516171819202122232425262728293031323334353637383940
  1. # Copyright 1999-2015 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=6
  4. # ebuild generated by hackport 0.4.5.9999
  5. CABAL_FEATURES="bin lib profile haddock hoogle hscolour"
  6. inherit haskell-cabal
  7. DESCRIPTION="Compiler for a simple functional language"
  8. HOMEPAGE="http://www.dcs.st-and.ac.uk/~eb/epic.php"
  9. SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
  10. LICENSE="BSD"
  11. SLOT="0/${PV}"
  12. KEYWORDS="~amd64 ~x86"
  13. IUSE=""
  14. RDEPEND="dev-haskell/cabal:=[profile?]
  15. dev-haskell/mtl:=[profile?]
  16. >=dev-libs/boehm-gc-7.0:0=[threads]
  17. dev-libs/gmp:0=
  18. >=dev-lang/ghc-7.4.1:=
  19. "
  20. DEPEND="${RDEPEND}
  21. >=dev-haskell/cabal-1.8.0.4
  22. dev-haskell/happy
  23. "
  24. # Bug #438422, upstream at https://github.com/edwinb/EpiVM/issues/5.
  25. PATCHES=("${FILESDIR}"/${PN}-0.9.3.3-respect-user-cflags.patch)
  26. src_prepare() {
  27. default
  28. # to disambiguare with net-irc/epic4, bug #432436
  29. cabal_chdeps \
  30. 'Executable epic' 'Executable epic-epivm'
  31. }