pcc-1.1.0-r1.ebuild 852 B

1234567891011121314151617181920212223242526272829303132333435363738
  1. # Copyright 1999-2015 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=5
  4. inherit eutils versionator autotools
  5. DESCRIPTION="pcc portable c compiler"
  6. HOMEPAGE="http://pcc.ludd.ltu.se"
  7. SRC_URI="ftp://pcc.ludd.ltu.se/pub/pcc-releases/${P}.tgz"
  8. LICENSE="BSD"
  9. SLOT="0"
  10. KEYWORDS="~x86 ~amd64 ~amd64-fbsd"
  11. IUSE=""
  12. DEPEND=">=dev-libs/pcc-libs-${PV}"
  13. RDEPEND="${DEPEND}"
  14. src_prepare() {
  15. sed -i -e 's/AC_CHECK_PROG(strip,strip,yes,no)//' configure.ac || die "Failed to fix configure.ac"
  16. sed -i -e 's/AC_SUBST(strip)//' configure.ac || die "Failed to fix configure.ac more"
  17. eautoreconf
  18. epatch "${FILESDIR}/${P}-multiarch.patch" || die
  19. }
  20. src_configure() {
  21. econf --disable-stripping
  22. }
  23. src_compile() {
  24. emake || die "emake failed"
  25. }
  26. src_install() {
  27. emake DESTDIR="${D}" install || die "emake install failed"
  28. }