busted-2.0_rc12_p1.ebuild 1.0 KB

1234567891011121314151617181920212223242526272829303132333435363738394041424344
  1. # Copyright 1999-2017 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=6
  4. inherit toolchain-funcs
  5. # The below is the upstream version number. The -x suffix should be kept
  6. # in sync with the _px suffix in the ebuild version.
  7. MY_PV="2.0.rc12-1"
  8. DESCRIPTION="Elegant Lua unit testing"
  9. HOMEPAGE="http://olivinelabs.com/busted/"
  10. SRC_URI="https://github.com/Olivine-Labs/${PN}/archive/v${MY_PV}.tar.gz -> ${P}.tar.gz"
  11. LICENSE="MIT"
  12. SLOT="0"
  13. KEYWORDS="amd64 ~x86"
  14. IUSE=""
  15. COMMON_DEPEND=">=dev-lang/lua-5.1:="
  16. DEPEND="${COMMON_DEPEND}
  17. virtual/pkgconfig"
  18. RDEPEND="${COMMON_DEPEND}
  19. >=dev-lua/lua_cliargs-3.0
  20. >=dev-lua/luafilesystem-1.5.0
  21. >=dev-lua/luasystem-0.2.0
  22. >=dev-lua/dkjson-2.1.0
  23. >=dev-lua/say-1.3
  24. >=dev-lua/luassert-1.7.8
  25. >=dev-lua/lua-term-0.1_p1
  26. >=dev-lua/penlight-1.3.2
  27. >=dev-lua/mediator_lua-1.1.1_p0
  28. "
  29. S="${WORKDIR}/${PN}-${MY_PV}"
  30. src_install() {
  31. dobin bin/busted
  32. insinto "$($(tc-getPKG_CONFIG) --variable INSTALL_LMOD lua)"/${PN}
  33. doins -r busted/*
  34. dodoc *.md
  35. }