lanes-3.10.0.ebuild 755 B

1234567891011121314151617181920212223242526272829303132
  1. # Copyright 1999-2015 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=5
  4. inherit eutils multilib toolchain-funcs
  5. DESCRIPTION="lightweight, native, lazy evaluating multithreading library"
  6. HOMEPAGE="https://github.com/LuaLanes/lanes"
  7. SRC_URI="https://github.com/LuaLanes/lanes/archive/v${PV}.tar.gz -> ${P}.tar.gz"
  8. LICENSE="MIT"
  9. SLOT="0"
  10. KEYWORDS="amd64"
  11. IUSE=""
  12. COMMON_DEPEND=">=dev-lang/lua-5.1"
  13. DEPEND="${COMMON_DEPEND}"
  14. RDEPEND="${COMMON_DEPEND}"
  15. src_prepare() {
  16. tc-export CC
  17. epatch "${FILESDIR}"/${P}-fix-makefile.patch
  18. sed -i -e "s#/lib#/$(get_libdir)#" Makefile || die "sed failed"
  19. }
  20. src_install() {
  21. emake DESTDIR="${D}" PREFIX=/usr install
  22. dodoc ABOUT BUGS CHANGES README TODO
  23. dohtml -r docs/*
  24. }