luajson-1.3.3.ebuild 700 B

1234567891011121314151617181920212223242526272829
  1. # Copyright 1999-2015 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=5
  4. DESCRIPTION="JSON Parser/Constructor for Lua"
  5. HOMEPAGE="http://www.eharning.us/wiki/luajson/"
  6. SRC_URI="https://github.com/harningt/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
  7. LICENSE="MIT"
  8. SLOT="0"
  9. KEYWORDS="~amd64 ~arm ~hppa ~mips ppc ppc64 sparc ~x86"
  10. IUSE="test"
  11. RDEPEND="|| ( >=dev-lang/lua-5.1 dev-lang/luajit:2 )
  12. dev-lua/lpeg"
  13. DEPEND="test? ( dev-lua/luafilesystem )"
  14. # lunit not in the tree yet
  15. RESTRICT="test"
  16. # nothing to compile
  17. src_compile() { :; }
  18. src_install() {
  19. emake PREFIX=/usr DESTDIR="${D}" install
  20. dodoc README docs/ReleaseNotes-${PV}.txt docs/LuaJSON.txt
  21. }