bin-prot-0.9.0.ebuild 920 B

12345678910111213141516171819202122232425262728293031323334353637383940414243
  1. # Copyright 1999-2017 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=6
  4. DESCRIPTION="Binary protocol generator"
  5. HOMEPAGE="https://github.com/janestreet/bin_prot"
  6. SRC_URI="https://github.com/janestreet/bin_prot/archive/v${PV}.tar.gz -> ${P}.tar.gz"
  7. LICENSE="Apache-2.0"
  8. SLOT="0/${PV}"
  9. KEYWORDS="~amd64"
  10. IUSE=""
  11. RDEPEND="
  12. dev-lang/ocaml:=
  13. dev-ml/base:=
  14. dev-ml/ppx_compare:=
  15. dev-ml/ppx_custom_printf:=
  16. dev-ml/ppx_driver:=
  17. dev-ml/ppx_fields_conv:=
  18. dev-ml/ppx_sexp_conv:=
  19. dev-ml/ppx_variants_conv:=
  20. dev-ml/sexplib:=
  21. dev-ml/ocaml-migrate-parsetree:=
  22. "
  23. DEPEND="${RDEPEND} dev-ml/opam dev-ml/jbuilder"
  24. S="${WORKDIR}/bin_prot-${PV}"
  25. src_test() {
  26. jbuilder runtest || die
  27. }
  28. src_install() {
  29. opam-installer -i \
  30. --prefix="${ED}/usr" \
  31. --libdir="${D}/$(ocamlc -where)" \
  32. --docdir="${ED}/usr/share/doc/${PF}" \
  33. ${PN/-/_}.install || die
  34. dodoc CHANGES.md README.md
  35. }