lwt-2.7.0.ebuild 957 B

123456789101112131415161718192021222324252627282930313233343536373839404142
  1. # Copyright 1999-2017 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=5
  4. OASIS_BUILD_TESTS=1
  5. OASIS_BUILD_DOCS=1
  6. inherit oasis
  7. DESCRIPTION="Cooperative light-weight thread library for OCaml"
  8. SRC_URI="https://github.com/ocsigen/lwt/archive/${PV}.tar.gz -> ${P}.tar.gz"
  9. HOMEPAGE="http://ocsigen.org/lwt"
  10. IUSE="+camlp4 gtk +ppx +react +ssl"
  11. DEPEND="react? ( >=dev-ml/react-1.2:= )
  12. dev-libs/libev
  13. >=dev-lang/ocaml-4.02:=
  14. ssl? ( >=dev-ml/ocaml-ssl-0.4.0:= )
  15. gtk? ( dev-ml/lablgtk:= dev-libs/glib:2 )
  16. ppx? ( dev-ml/ppx_tools:= )
  17. camlp4? ( dev-ml/camlp4:= )"
  18. RDEPEND="${DEPEND}
  19. !<www-servers/ocsigen-1.1"
  20. SLOT="0/${PV}"
  21. LICENSE="LGPL-2.1-with-linking-exception"
  22. KEYWORDS="~amd64 ~arm ~ppc ~x86-fbsd"
  23. DOCS=( "CHANGES" "README.md" )
  24. src_configure() {
  25. oasis_configure_opts="$(use_enable gtk glib)
  26. $(use_enable react)
  27. $(use_enable ssl)
  28. $(use_enable camlp4)
  29. $(use_enable ppx)" \
  30. oasis_src_configure
  31. }