spawn-0.9.0.ebuild 610 B

12345678910111213141516171819202122232425262728
  1. # Copyright 1999-2017 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=6
  4. DESCRIPTION="Spawning sub-processes"
  5. HOMEPAGE="https://github.com/janestreet/spawn"
  6. SRC_URI="https://github.com/janestreet/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
  7. LICENSE="Apache-2.0"
  8. SLOT="0/${PV}"
  9. KEYWORDS="~amd64"
  10. IUSE=""
  11. DEPEND="
  12. dev-lang/ocaml:=
  13. "
  14. RDEPEND="${DEPEND}"
  15. DEPEND="${DEPEND} dev-ml/opam dev-ml/jbuilder"
  16. src_install() {
  17. opam-installer -i \
  18. --prefix="${ED}/usr" \
  19. --libdir="${D}/$(ocamlc -where)" \
  20. --docdir="${ED}/usr/share/doc/${PF}" \
  21. ${PN}.install || die
  22. }