pecl-mailparse-2.1.6-r3.ebuild 624 B

1234567891011121314151617181920212223242526272829303132
  1. # Copyright 1999-2016 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=6
  4. PHP_EXT_NAME="mailparse"
  5. DOCS=( README )
  6. USE_PHP="php5-5 php5-6"
  7. inherit php-ext-pecl-r3
  8. KEYWORDS="amd64 ppc ppc64 x86"
  9. DESCRIPTION="PHP extension for parsing RFC822 and RFC2045 (MIME) messages"
  10. LICENSE="PHP-2.02"
  11. SLOT="0"
  12. IUSE=""
  13. for _target in ${USE_PHP}; do
  14. _slot=${_target/php}
  15. _slot=${_slot/-/.}
  16. _PHPUSEDEPEND="${_PHPUSEDEPEND}
  17. php_targets_${_target}? ( dev-lang/php:${_slot}[unicode] )"
  18. done
  19. unset slot target
  20. RDEPEND="${_PHPUSEDEPEND}"
  21. unset _PHPUSEDEPEND
  22. DEPEND="${RDEPEND}
  23. dev-util/re2c"