pecl-mailparse-2.1.6-r4.ebuild 839 B

12345678910111213141516171819202122232425262728293031323334353637383940414243
  1. # Copyright 1999-2017 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=6
  4. PHP_EXT_NAME="mailparse"
  5. PHP_EXT_ECONF_ARGS=""
  6. DOCS=( README )
  7. USE_PHP="php5-6 php7-0 php7-1"
  8. inherit php-ext-pecl-r3
  9. USE_PHP="php5-6"
  10. KEYWORDS="amd64 ppc ppc64 x86"
  11. DESCRIPTION="PHP extension for parsing RFC822 and RFC2045 (MIME) messages"
  12. LICENSE="PHP-2.02"
  13. SLOT="0"
  14. IUSE=""
  15. RDEPEND="php_targets_php5-6? ( dev-lang/php:5.6[unicode] )"
  16. DEPEND="${RDEPEND}
  17. dev-util/re2c"
  18. PDEPEND="
  19. php_targets_php7-0? ( dev-php/pecl-mailparse:7[php_targets_php7-0] )
  20. php_targets_php7-1? ( dev-php/pecl-mailparse:7[php_targets_php7-1] )
  21. "
  22. src_prepare() {
  23. if use php_targets_php5-6 ; then
  24. php-ext-source-r3_src_prepare
  25. else
  26. eapply_user
  27. fi
  28. }
  29. src_install() {
  30. if use php_targets_php5-6 ; then
  31. php-ext-pecl-r3_src_install
  32. fi
  33. }