123456789101112131415161718192021222324252627282930313233343536373839404142434445 |
- # Copyright 1999-2017 Gentoo Foundation
- # Distributed under the terms of the GNU General Public License v2
- EAPI=6
- DESCRIPTION="Symfony DependencyInjection Component"
- HOMEPAGE="https://github.com/symfony/dependency-injection"
- SRC_URI="https://github.com/symfony/dependency-injection/archive/v${PV}.tar.gz
- -> ${P}.tar.gz"
- LICENSE="MIT"
- SLOT="0"
- KEYWORDS="~amd64 ~x86"
- IUSE="test"
- RESTRICT="test"
- RDEPEND="
- dev-lang/php:*
- dev-php/fedora-autoloader
- >=dev-php/symfony-config-2.1.0
- >=dev-php/symfony-yaml-2.1.0"
- DEPEND="
- test? (
- ${RDEPEND}
- dev-php/phpunit )"
- S="${WORKDIR}/dependency-injection-${PV}"
- src_prepare() {
- default
- if use test; then
- cp "${FILESDIR}"/autoload.php "${S}"/autoload-test.php || die
- fi
- }
- src_install() {
- insinto "/usr/share/php/Symfony/Component/DependencyInjection"
- doins -r . "${FILESDIR}"/autoload.php
- dodoc README.md
- }
- src_test() {
- phpunit --bootstrap "${S}"/autoload-test.php || die "test suite failed"
- }
|