bondpy-9999.ebuild 524 B

123456789101112131415161718192021222324
  1. # Copyright 1999-2014 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=5
  4. ROS_REPO_URI="https://github.com/ros/bond_core"
  5. KEYWORDS="~amd64 ~arm"
  6. ROS_SUBDIR=${PN}
  7. PYTHON_COMPAT=( python2_7 )
  8. inherit ros-catkin
  9. DESCRIPTION="Python implementation of bond, a mechanism for checking when another process has terminated"
  10. LICENSE="BSD"
  11. SLOT="0"
  12. IUSE=""
  13. RDEPEND="
  14. dev-ros/bond[${PYTHON_USEDEP}]
  15. dev-ros/rospy[${PYTHON_USEDEP}]
  16. dev-ros/smclib
  17. sys-apps/util-linux
  18. "
  19. DEPEND="${RDEPEND}"