camera_calibration-1.12.18.ebuild 828 B

12345678910111213141516171819202122232425262728
  1. # Copyright 1999-2016 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=5
  4. ROS_REPO_URI="https://github.com/ros-perception/image_pipeline"
  5. KEYWORDS="~amd64 ~arm"
  6. PYTHON_COMPAT=( python2_7 )
  7. ROS_SUBDIR=${PN}
  8. inherit ros-catkin
  9. DESCRIPTION="Calibration of monocular or stereo cameras using a checkerboard calibration target"
  10. LICENSE="BSD"
  11. SLOT="0"
  12. IUSE=""
  13. RDEPEND="
  14. dev-ros/cv_bridge[${PYTHON_USEDEP}]
  15. dev-ros/image_geometry[${PYTHON_USEDEP}]
  16. || ( media-libs/opencv[python,${PYTHON_USEDEP}] media-libs/opencv[python,python_single_target_python2_7] )
  17. dev-ros/message_filters[${PYTHON_USEDEP}]
  18. dev-ros/rospy[${PYTHON_USEDEP}]
  19. dev-ros/std_srvs[${PYTHON_USEDEP}]
  20. dev-ros/sensor_msgs[${CATKIN_MESSAGES_PYTHON_USEDEP}]
  21. "
  22. DEPEND="${RDEPEND}
  23. test? ( dev-python/nose[${PYTHON_USEDEP}] )"