dwa_local_planner-9999.ebuild 693 B

1234567891011121314151617181920212223242526272829303132
  1. # Copyright 1999-2016 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=5
  4. ROS_REPO_URI="https://github.com/ros-planning/navigation"
  5. ROS_SUBDIR=${PN}
  6. KEYWORDS="~amd64 ~arm"
  7. PYTHON_COMPAT=( python2_7 )
  8. inherit ros-catkin
  9. DESCRIPTION="Dynamic Window Approach to local robot navigation on a plane"
  10. LICENSE="BSD"
  11. SLOT="0"
  12. IUSE=""
  13. RDEPEND="
  14. dev-ros/base_local_planner
  15. dev-ros/costmap_2d
  16. dev-ros/dynamic_reconfigure[${PYTHON_USEDEP}]
  17. dev-ros/nav_core
  18. dev-ros/nav_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
  19. dev-ros/pluginlib
  20. dev-ros/pcl_conversions
  21. dev-ros/roscpp
  22. dev-ros/tf
  23. dev-cpp/eigen:3
  24. sci-libs/pcl
  25. dev-libs/boost:=[threads]
  26. "
  27. DEPEND="${RDEPEND}"