dynamic_reconfigure-1.5.46.ebuild 574 B

123456789101112131415161718192021222324
  1. # Copyright 1999-2017 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=5
  4. CATKIN_HAS_MESSAGES=yes
  5. ROS_REPO_URI="https://github.com/ros/dynamic_reconfigure"
  6. KEYWORDS="~amd64 ~arm"
  7. PYTHON_COMPAT=( python{2_7,3_4,3_5} )
  8. CATKIN_MESSAGES_TRANSITIVE_DEPS="dev-ros/std_msgs"
  9. inherit ros-catkin
  10. DESCRIPTION="Provides a means to change node parameters at any time without having to restart the node"
  11. LICENSE="BSD"
  12. SLOT="0"
  13. IUSE=""
  14. RDEPEND="
  15. dev-libs/boost:=[threads]
  16. dev-ros/rospy[${PYTHON_USEDEP}]
  17. dev-ros/roscpp
  18. "
  19. DEPEND="${RDEPEND}"