gencpp-9999.ebuild 465 B

1234567891011121314151617181920
  1. # Copyright 1999-2017 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=5
  4. ROS_REPO_URI="https://github.com/ros/gencpp"
  5. KEYWORDS="~amd64 ~arm"
  6. PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} pypy{,3} )
  7. inherit ros-catkin
  8. DESCRIPTION="ROS C++ message definition and serialization generators"
  9. HOMEPAGE="http://wiki.ros.org/gencpp"
  10. LICENSE="BSD"
  11. SLOT="0/${PV}"
  12. IUSE=""
  13. RDEPEND="dev-ros/genmsg[${PYTHON_USEDEP}]"
  14. DEPEND="${RDEPEND}"