genpy-0.6.5.ebuild 536 B

12345678910111213141516171819202122232425
  1. # Copyright 1999-2017 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=5
  4. ROS_REPO_URI="https://github.com/ros/genpy"
  5. KEYWORDS="~amd64 ~arm"
  6. PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} pypy{,3} )
  7. inherit ros-catkin
  8. DESCRIPTION="Python ROS message and service generators"
  9. HOMEPAGE="http://wiki.ros.org/genpy"
  10. LICENSE="BSD"
  11. SLOT="0/${PV}"
  12. IUSE=""
  13. RDEPEND="dev-ros/genmsg[${PYTHON_USEDEP}]"
  14. DEPEND="${RDEPEND}
  15. test? (
  16. dev-python/pyyaml[${PYTHON_USEDEP}]
  17. dev-python/nose[${PYTHON_USEDEP}]
  18. )
  19. "