hector_geotiff-0.3.4.ebuild 682 B

12345678910111213141516171819202122232425262728
  1. # Copyright 1999-2014 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=5
  4. ROS_REPO_URI="https://github.com/tu-darmstadt-ros-pkg/hector_slam"
  5. KEYWORDS="~amd64 ~arm"
  6. ROS_SUBDIR=${PN}
  7. inherit ros-catkin
  8. DESCRIPTION="Node to save occupancy grid map, robot trajectory and object of interest data to GeoTiff images"
  9. LICENSE="BSD"
  10. SLOT="0"
  11. IUSE=""
  12. RDEPEND="
  13. dev-ros/hector_map_tools
  14. dev-ros/hector_nav_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
  15. dev-ros/nav_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
  16. dev-ros/pluginlib
  17. dev-ros/roscpp
  18. dev-ros/std_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
  19. dev-qt/qtcore:4
  20. dev-qt/qtgui:4
  21. "
  22. DEPEND="${RDEPEND}
  23. dev-cpp/eigen:3"