imu_processors-9999.ebuild 536 B

123456789101112131415161718192021222324
  1. # Copyright 1999-2014 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=5
  4. ROS_REPO_URI="https://github.com/ros-perception/imu_pipeline"
  5. KEYWORDS="~amd64 ~arm"
  6. ROS_SUBDIR=${PN}
  7. inherit ros-catkin
  8. DESCRIPTION="Processors for sensor_msgs::Imu data"
  9. LICENSE="BSD"
  10. SLOT="0"
  11. IUSE=""
  12. RDEPEND="
  13. dev-ros/roscpp
  14. dev-ros/tf
  15. dev-ros/sensor_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
  16. dev-ros/geometry_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
  17. dev-ros/nav_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
  18. "
  19. DEPEND="${RDEPEND}"