imu_transformer-0.2.2.ebuild 665 B

1234567891011121314151617181920212223242526272829
  1. # Copyright 1999-2017 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=5
  4. ROS_REPO_URI="https://github.com/ros-perception/imu_pipeline"
  5. KEYWORDS="~amd64 ~arm"
  6. ROS_SUBDIR=${PN}
  7. inherit ros-catkin
  8. DESCRIPTION="Node/nodelet combination to transform sensor_msgs::Imu data from one frame into another"
  9. LICENSE="GPL-2"
  10. SLOT="0"
  11. IUSE=""
  12. RDEPEND="
  13. dev-ros/message_filters
  14. dev-ros/nodelet
  15. dev-ros/roscpp
  16. dev-ros/roslaunch
  17. dev-ros/tf2
  18. dev-ros/tf2_ros
  19. dev-ros/topic_tools
  20. dev-ros/tf2_sensor_msgs
  21. dev-ros/sensor_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
  22. dev-ros/geometry_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
  23. "
  24. DEPEND="${RDEPEND}"