joint_limits_interface-0.11.4.ebuild 490 B

12345678910111213141516171819202122232425
  1. # Copyright 1999-2017 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=5
  4. ROS_REPO_URI="https://github.com/ros-controls/ros_control"
  5. KEYWORDS="~amd64"
  6. ROS_SUBDIR=${PN}
  7. PYTHON_COMPAT=( python2_7 )
  8. inherit ros-catkin
  9. DESCRIPTION="Interface for enforcing joint limits"
  10. LICENSE="BSD"
  11. SLOT="0"
  12. IUSE=""
  13. RDEPEND="
  14. dev-ros/roscpp
  15. dev-ros/hardware_interface
  16. dev-libs/urdfdom
  17. dev-ros/urdf
  18. "
  19. DEPEND="${RDEPEND}
  20. test? ( dev-ros/rostest dev-cpp/gtest )"