kdl_parser_py-1.12.5.ebuild 487 B

12345678910111213141516171819202122
  1. # Copyright 1999-2016 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=5
  4. ROS_REPO_URI="https://github.com/ros/robot_model"
  5. KEYWORDS="~amd64 ~arm"
  6. ROS_SUBDIR=${PN}
  7. PYTHON_COMPAT=( python2_7 )
  8. inherit ros-catkin
  9. DESCRIPTION="Python tools to construct a KDL tree from an XML robot representation in URDF"
  10. LICENSE="BSD"
  11. SLOT="0"
  12. IUSE=""
  13. RDEPEND="
  14. dev-ros/urdf[${PYTHON_USEDEP}]
  15. "
  16. DEPEND="${RDEPEND}
  17. test? ( dev-ros/rostest[${PYTHON_USEDEP}] )"