nodelet_topic_tools-1.9.10.ebuild 539 B

1234567891011121314151617181920212223242526
  1. # Copyright 1999-2017 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=5
  4. ROS_REPO_URI="https://github.com/ros/nodelet_core"
  5. KEYWORDS="~amd64 ~arm"
  6. ROS_SUBDIR=${PN}
  7. PYTHON_COMPAT=( python2_7 )
  8. inherit ros-catkin
  9. DESCRIPTION="Common nodelet tools such as a mux, demux and throttle"
  10. LICENSE="BSD"
  11. SLOT="0"
  12. IUSE=""
  13. RDEPEND="
  14. dev-libs/boost:=[threads]
  15. dev-ros/dynamic_reconfigure[${PYTHON_USEDEP}]
  16. dev-ros/message_filters
  17. dev-ros/nodelet
  18. dev-ros/pluginlib
  19. dev-ros/roscpp
  20. "
  21. DEPEND="${RDEPEND}"