polled_camera-1.11.10.ebuild 600 B

12345678910111213141516171819202122232425
  1. # Copyright 1999-2014 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=5
  4. ROS_REPO_URI="https://github.com/ros-perception/image_common"
  5. KEYWORDS="~amd64 ~arm"
  6. ROS_SUBDIR=${PN}
  7. CATKIN_HAS_MESSAGES=yes
  8. PYTHON_COMPAT=( python{2_7,3_4} )
  9. CATKIN_MESSAGES_TRANSITIVE_DEPS="dev-ros/std_msgs dev-ros/sensor_msgs"
  10. inherit ros-catkin
  11. DESCRIPTION="C++ helper classes for implementing a polled camera driver node and requesting images from it"
  12. LICENSE="BSD"
  13. SLOT="0"
  14. IUSE=""
  15. RDEPEND="
  16. dev-ros/roscpp
  17. dev-ros/image_transport
  18. dev-ros/rosconsole
  19. "
  20. DEPEND="${RDEPEND}"