realtime_tools-1.9.2.ebuild 487 B

12345678910111213141516171819202122
  1. # Copyright 1999-2016 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=5
  4. ROS_REPO_URI="https://github.com/ros-controls/realtime_tools"
  5. KEYWORDS="~amd64"
  6. PYTHON_COMPAT=( python2_7 )
  7. inherit ros-catkin
  8. DESCRIPTION="Set of tools that can be used from a hard realtime thread, without breaking the realtime behavior"
  9. LICENSE="BSD"
  10. SLOT="0"
  11. IUSE=""
  12. RDEPEND="
  13. dev-ros/roscpp
  14. dev-ros/rospy[${PYTHON_USEDEP}]
  15. dev-libs/boost:=
  16. "
  17. DEPEND="${RDEPEND}"