12345678910111213141516171819202122232425262728 |
- # Copyright 1999-2017 Gentoo Foundation
- # Distributed under the terms of the GNU General Public License v2
- EAPI=5
- KEYWORDS="~amd64"
- ROS_REPO_URI="https://github.com/ros-visualization/rqt_common_plugins"
- PYTHON_COMPAT=( python2_7 )
- ROS_SUBDIR=${PN}
- inherit ros-catkin
- DESCRIPTION="GUI plugin for visualizing the ROS dependency graph"
- LICENSE="BSD"
- SLOT="0"
- IUSE=""
- RDEPEND="
- dev-python/rospkg[${PYTHON_USEDEP}]
- dev-ros/qt_dotgraph[${PYTHON_USEDEP}]
- dev-ros/qt_gui[${PYTHON_USEDEP}]
- dev-ros/qt_gui_py_common[${PYTHON_USEDEP}]
- dev-ros/rqt_graph[${PYTHON_USEDEP}]
- dev-ros/rqt_gui_py[${PYTHON_USEDEP}]
- "
- DEPEND="${RDEPEND}
- test? ( dev-python/nose[${PYTHON_USEDEP}] )"
|