rqt_py_console-0.4.6.ebuild 628 B

123456789101112131415161718192021222324252627
  1. # Copyright 1999-2017 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=5
  4. KEYWORDS="~amd64"
  5. ROS_REPO_URI="https://github.com/ros-visualization/rqt_common_plugins"
  6. PYTHON_COMPAT=( python2_7 )
  7. ROS_SUBDIR=${PN}
  8. inherit ros-catkin
  9. DESCRIPTION="Python GUI plugin providing an interactive Python console"
  10. LICENSE="BSD"
  11. SLOT="0"
  12. IUSE=""
  13. RDEPEND="
  14. dev-python/rospkg[${PYTHON_USEDEP}]
  15. dev-ros/qt_gui[${PYTHON_USEDEP}]
  16. dev-ros/qt_gui_py_common[${PYTHON_USEDEP}]
  17. dev-ros/rospy[${PYTHON_USEDEP}]
  18. dev-ros/rqt_gui[${PYTHON_USEDEP}]
  19. dev-ros/rqt_gui_py[${PYTHON_USEDEP}]
  20. "
  21. DEPEND="${RDEPEND}"