rqt_robot_steering-0.5.3.ebuild 604 B

1234567891011121314151617181920212223242526
  1. # Copyright 1999-2016 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=5
  4. KEYWORDS="~amd64"
  5. ROS_REPO_URI="https://github.com/ros-visualization/rqt_robot_plugins"
  6. PYTHON_COMPAT=( python2_7 )
  7. ROS_SUBDIR=${PN}
  8. inherit ros-catkin
  9. DESCRIPTION="GUI plugin for steering a robot using Twist messages"
  10. LICENSE="BSD"
  11. SLOT="0"
  12. IUSE=""
  13. RDEPEND="
  14. dev-ros/geometry_msgs[${CATKIN_MESSAGES_PYTHON_USEDEP}]
  15. dev-python/rospkg[${PYTHON_USEDEP}]
  16. dev-ros/rostopic[${PYTHON_USEDEP}]
  17. dev-ros/rqt_gui[${PYTHON_USEDEP}]
  18. dev-ros/rqt_gui_py[${PYTHON_USEDEP}]
  19. "
  20. DEPEND="${RDEPEND}"