rqt_rviz-0.5.6.ebuild 545 B

12345678910111213141516171819202122232425262728
  1. # Copyright 1999-2017 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=5
  4. KEYWORDS="~amd64"
  5. ROS_REPO_URI="https://github.com/ros-visualization/rqt_robot_plugins"
  6. PYTHON_COMPAT=( python2_7 )
  7. ROS_SUBDIR=${PN}
  8. inherit ros-catkin
  9. DESCRIPTION="GUI plugin embedding RViz"
  10. LICENSE="BSD"
  11. SLOT="0"
  12. IUSE=""
  13. RDEPEND="
  14. dev-libs/boost:=
  15. dev-ros/pluginlib[${PYTHON_USEDEP}]
  16. dev-ros/rqt_gui[${PYTHON_USEDEP}]
  17. dev-ros/rqt_gui_cpp
  18. >=dev-ros/qt_gui_cpp-0.3
  19. dev-qt/qtwidgets:5
  20. dev-ros/rviz
  21. "
  22. DEPEND="${RDEPEND}"