test_bond-1.7.19.ebuild 475 B

123456789101112131415161718192021222324
  1. # Copyright 1999-2017 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=5
  4. ROS_REPO_URI="https://github.com/ros/bond_core"
  5. KEYWORDS="~amd64 ~arm"
  6. CATKIN_HAS_MESSAGES=yes
  7. ROS_SUBDIR=${PN}
  8. PYTHON_COMPAT=( python2_7 )
  9. inherit ros-catkin
  10. DESCRIPTION="Tests for bond, bondpy and bondcpp"
  11. LICENSE="BSD"
  12. SLOT="0"
  13. IUSE=""
  14. RDEPEND="
  15. dev-ros/bondcpp
  16. dev-ros/bondpy[${PYTHON_USEDEP}]
  17. dev-ros/rostest[${PYTHON_USEDEP}]
  18. "
  19. DEPEND="${RDEPEND}"