test_rosbag-1.12.5.ebuild 840 B

12345678910111213141516171819202122232425262728293031323334353637383940
  1. # Copyright 1999-2016 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=5
  4. ROS_REPO_URI="https://github.com/ros/ros_comm"
  5. KEYWORDS="~amd64 ~arm"
  6. ROS_SUBDIR=test/${PN}
  7. PYTHON_COMPAT=( python2_7 )
  8. CATKIN_HAS_MESSAGES=yes
  9. CATKIN_MESSAGES_TRANSITIVE_DEPS="dev-ros/rosgraph_msgs dev-ros/std_msgs"
  10. inherit ros-catkin
  11. DESCRIPTION="Unit tests for rosbag"
  12. LICENSE="BSD"
  13. SLOT="0"
  14. IUSE=""
  15. RDEPEND="
  16. dev-ros/message_generation
  17. dev-ros/rosbag[${PYTHON_USEDEP}]
  18. dev-ros/rosconsole
  19. dev-ros/roscpp
  20. dev-ros/rostest[${PYTHON_USEDEP}]
  21. dev-ros/rosunit[${PYTHON_USEDEP}]
  22. dev-ros/topic_tools[${PYTHON_USEDEP}]
  23. dev-ros/xmlrpcpp
  24. "
  25. DEPEND="${RDEPEND}
  26. test? (
  27. dev-libs/boost[threads]
  28. app-arch/bzip2
  29. dev-ros/rosout
  30. dev-python/nose[${PYTHON_USEDEP}]
  31. dev-ros/rostest[${PYTHON_USEDEP}]
  32. dev-cpp/gtest
  33. )
  34. "