test_roslaunch-1.12.2.ebuild 483 B

1234567891011121314151617181920212223242526
  1. # Copyright 1999-2016 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=5
  4. ROS_REPO_URI="https://github.com/ros/ros_comm"
  5. KEYWORDS="~amd64 ~arm"
  6. ROS_SUBDIR=test/${PN}
  7. PYTHON_COMPAT=( python2_7 )
  8. inherit ros-catkin
  9. DESCRIPTION="Unit tests for roslaunch"
  10. LICENSE="BSD"
  11. SLOT="0"
  12. IUSE=""
  13. RDEPEND=""
  14. DEPEND="${RDEPEND}
  15. dev-ros/rostest[${PYTHON_USEDEP}]
  16. test? (
  17. dev-ros/roslaunch[${PYTHON_USEDEP}]
  18. dev-python/rospkg[${PYTHON_USEDEP}]
  19. )
  20. "