test_rosmaster-1.12.7.ebuild 698 B

12345678910111213141516171819202122232425262728293031323334
  1. # Copyright 1999-2017 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=5
  4. ROS_REPO_URI="https://github.com/ros/ros_comm"
  5. KEYWORDS="~amd64 ~arm"
  6. ROS_SUBDIR=test/${PN}
  7. CATKIN_HAS_MESSAGES=yes
  8. PYTHON_COMPAT=( python2_7 )
  9. inherit ros-catkin
  10. DESCRIPTION="Unit tests for rosmaster"
  11. LICENSE="BSD"
  12. SLOT="0"
  13. IUSE=""
  14. RDEPEND="dev-ros/rosgraph[${PYTHON_USEDEP}]
  15. dev-ros/rostest[${PYTHON_USEDEP}]
  16. dev-ros/std_msgs[${PYTHON_USEDEP}]"
  17. DEPEND="${RDEPEND}
  18. test? ( dev-ros/roslib[${PYTHON_USEDEP}] )
  19. "
  20. mycatkincmakeargs=( "-DCATKIN_ENABLE_TESTING=ON" )
  21. src_install() {
  22. ros-catkin_src_install
  23. dodir /usr/share/${PN}
  24. cp -a test "${ED}//usr/share/${PN}/" || die
  25. }