test_rosparam-1.12.5.ebuild 503 B

123456789101112131415161718192021222324252627
  1. # Copyright 1999-2016 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=5
  4. ROS_REPO_URI="https://github.com/ros/ros_comm"
  5. KEYWORDS="~amd64 ~arm"
  6. ROS_SUBDIR=test/${PN}
  7. CATKIN_HAS_MESSAGES=yes
  8. PYTHON_COMPAT=( python2_7 )
  9. inherit ros-catkin
  10. DESCRIPTION="Unit tests for rosparam"
  11. LICENSE="BSD"
  12. SLOT="0"
  13. IUSE=""
  14. RDEPEND=""
  15. DEPEND="${RDEPEND}
  16. dev-ros/rostest[${PYTHON_USEDEP}]
  17. test? (
  18. dev-python/nose[${PYTHON_USEDEP}]
  19. dev-ros/rosparam[${PYTHON_USEDEP}]
  20. )"