test_rosservice-1.12.2.ebuild 679 B

12345678910111213141516171819202122232425262728293031
  1. # Copyright 1999-2016 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=5
  4. ROS_REPO_URI="https://github.com/ros/ros_comm"
  5. KEYWORDS="~amd64 ~arm"
  6. ROS_SUBDIR=test/${PN}
  7. CATKIN_HAS_MESSAGES=yes
  8. CATKIN_MESSAGES_TRANSITIVE_DEPS="dev-ros/std_msgs"
  9. PYTHON_COMPAT=( python2_7 )
  10. inherit ros-catkin
  11. DESCRIPTION="Unit tests for rospy"
  12. LICENSE="BSD"
  13. SLOT="0"
  14. IUSE=""
  15. RDEPEND=""
  16. DEPEND="${RDEPEND}
  17. dev-ros/rostest[${PYTHON_USEDEP}]
  18. dev-ros/std_msgs[${CATKIN_MESSAGES_PYTHON_USEDEP}]
  19. test? (
  20. dev-ros/test_rosmaster[${PYTHON_USEDEP}]
  21. dev-ros/rospy[${PYTHON_USEDEP}]
  22. dev-ros/rostest[${PYTHON_USEDEP}]
  23. dev-python/nose[${PYTHON_USEDEP}]
  24. )"