tf2-9999.ebuild 521 B

123456789101112131415161718192021222324
  1. # Copyright 1999-2017 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=5
  4. ROS_REPO_URI="https://github.com/ros/geometry2"
  5. KEYWORDS="~amd64 ~arm"
  6. ROS_SUBDIR=${PN}
  7. inherit ros-catkin
  8. DESCRIPTION="The second generation Transform Library in ROS"
  9. LICENSE="BSD"
  10. SLOT="0"
  11. IUSE=""
  12. RDEPEND="
  13. dev-ros/tf2_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
  14. dev-libs/console_bridge
  15. dev-ros/rostime
  16. dev-ros/geometry_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
  17. dev-libs/boost:=[threads]
  18. "
  19. DEPEND="${RDEPEND}"