topic_tools-1.11.15.ebuild 695 B

12345678910111213141516171819202122232425262728293031323334
  1. # Copyright 1999-2014 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=5
  4. ROS_REPO_URI="https://github.com/ros/ros_comm"
  5. KEYWORDS="~amd64 ~arm"
  6. CATKIN_HAS_MESSAGES=yes
  7. ROS_SUBDIR=tools/${PN}
  8. PYTHON_COMPAT=( python2_7 )
  9. CATKIN_MESSAGES_TRANSITIVE_DEPS="dev-ros/std_msgs"
  10. inherit ros-catkin
  11. DESCRIPTION="Tools for directing, throttling and selecting ROS topics"
  12. LICENSE="BSD"
  13. SLOT="0"
  14. IUSE=""
  15. RDEPEND="
  16. dev-ros/cpp_common
  17. dev-ros/rosconsole
  18. dev-ros/roscpp
  19. dev-ros/rostime
  20. dev-ros/xmlrpcpp
  21. "
  22. DEPEND="${RDEPEND}
  23. test? (
  24. dev-ros/rostest[${PYTHON_USEDEP}]
  25. dev-ros/rosunit[${PYTHON_USEDEP}]
  26. dev-cpp/gtest
  27. dev-python/nose[${PYTHON_USEDEP}]
  28. )"