turtle_tf2-0.2.2.ebuild 658 B

123456789101112131415161718192021222324252627
  1. # Copyright 1999-2014 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=5
  4. ROS_REPO_URI="https://github.com/ros/geometry_tutorials"
  5. KEYWORDS="~amd64 ~arm"
  6. ROS_SUBDIR=${PN}
  7. PYTHON_COMPAT=( python2_7 )
  8. inherit ros-catkin
  9. DESCRIPTION="Demonstrates how to write a tf2 broadcaster and listener with the turtlesim"
  10. LICENSE="BSD"
  11. SLOT="0"
  12. IUSE=""
  13. RDEPEND="
  14. dev-ros/roscpp
  15. dev-ros/rospy[${PYTHON_USEDEP}]
  16. dev-ros/tf2
  17. dev-ros/tf2_ros[${PYTHON_USEDEP}]
  18. dev-ros/turtlesim[${PYTHON_USEDEP}]
  19. dev-ros/geometry_msgs[${CATKIN_MESSAGES_PYTHON_USEDEP}]
  20. dev-ros/std_msgs[${CATKIN_MESSAGES_PYTHON_USEDEP}]
  21. "
  22. DEPEND="${RDEPEND}"