elk-3.99.8.ebuild 672 B

12345678910111213141516171819202122232425262728293031
  1. # Copyright 1999-2012 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI="4"
  4. DESCRIPTION="Scheme implementation designed to be embeddable extension to C/C++ applications"
  5. HOMEPAGE="http://sam.zoy.org/elk"
  6. SRC_URI="http://sam.zoy.org/elk/${P}.tar.bz2"
  7. LICENSE="GPL-2"
  8. SLOT="0"
  9. KEYWORDS="~amd64"
  10. IUSE=""
  11. DEPEND=""
  12. src_compile() {
  13. # parallel build is broken
  14. emake -j1 || die "Make failed!"
  15. }
  16. # tests are run automatically during make and fail with default src_test
  17. src_test() {
  18. echo "Tests already run during compile"
  19. }
  20. src_install() {
  21. # parallel install is broken
  22. emake -j1 DESTDIR="${D}" install || die "Install failed"
  23. }