gauche-0.9.3.3.ebuild 1.1 KB

1234567891011121314151617181920212223242526272829303132333435363738394041424344454647484950515253
  1. # Copyright 1999-2016 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI="6"
  4. inherit autotools eutils
  5. MY_P="${P^g}"
  6. DESCRIPTION="A Unix system friendly Scheme Interpreter"
  7. HOMEPAGE="http://practical-scheme.net/gauche/"
  8. SRC_URI="mirror://sourceforge/${PN}/${MY_P}.tgz"
  9. LICENSE="BSD"
  10. SLOT="0"
  11. KEYWORDS="~alpha ~amd64 ia64 ~ppc ~ppc64 ~sparc x86 ~amd64-linux ~x86-linux ~x86-macos"
  12. IUSE="ipv6 test"
  13. RDEPEND="sys-libs/gdbm"
  14. DEPEND="${RDEPEND}
  15. test? ( dev-libs/openssl )"
  16. S="${WORKDIR}/${MY_P}"
  17. PATCHES=(
  18. "${FILESDIR}"/${PN}-0.9-rpath.patch
  19. "${FILESDIR}"/${PN}-0.9-gauche.m4.patch
  20. "${FILESDIR}"/${PN}-0.9-ext-ldflags.patch
  21. "${FILESDIR}"/${PN}-0.9-xz-info.patch
  22. "${FILESDIR}"/${PN}-0.9-rfc.tls.patch
  23. "${FILESDIR}"/${P}-gauche.threads.patch
  24. "${FILESDIR}"/${P}-file.util.patch
  25. )
  26. src_prepare() {
  27. default
  28. eautoconf
  29. }
  30. src_configure() {
  31. econf \
  32. $(use_enable ipv6) \
  33. --with-slib="${EPREFIX}"/usr/share/slib
  34. }
  35. src_test() {
  36. emake -j1 -s check
  37. }
  38. src_install() {
  39. emake -j1 DESTDIR="${D}" install-pkg install-doc
  40. dodoc AUTHORS ChangeLog HACKING README
  41. }