jscheme-7.2.ebuild 712 B

1234567891011121314151617181920212223242526272829303132333435
  1. # Copyright 1999-2012 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI="3"
  4. inherit java-utils-2 java-pkg-2
  5. DESCRIPTION="JScheme is a dialect of Scheme with a very simple interface to Java, called the Javadot notation"
  6. HOMEPAGE="http://jscheme.sourceforge.net/jscheme/main.html"
  7. SRC_URI="mirror://sourceforge/${PN}/${P}.tgz"
  8. LICENSE="Apache-1.1"
  9. SLOT="0"
  10. KEYWORDS="~amd64 ~x86"
  11. IUSE="doc"
  12. DEPEND=">=virtual/jdk-1.6"
  13. RDEPEND=">=virtual/jre-1.6
  14. ${DEPEND}"
  15. src_compile() {
  16. sh bin/make || die "make failed"
  17. }
  18. src_install() {
  19. java-pkg_dojar lib/*.jar
  20. java-pkg_dolauncher ${PN} \
  21. --main jscheme.REPL
  22. if use doc; then
  23. dohtml -r doc || die "dohtml failed"
  24. fi
  25. }