bera-20040930.ebuild 1.0 KB

12345678910111213141516171819202122232425262728293031323334353637383940414243444546474849505152535455
  1. # Copyright 1999-2009 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. inherit latex-package
  4. MY_P=${PN}
  5. S=${WORKDIR}/${MY_P}
  6. SUPPLIER="public"
  7. DESCRIPTION="LaTeX package for the Bera Type1 font family"
  8. HOMEPAGE="http://www.ctan.org/tex-archive/fonts/bera/"
  9. SRC_URI="mirror://gentoo/${P}.zip"
  10. LICENSE="LPPL-1.2"
  11. DEPEND="app-arch/unzip"
  12. KEYWORDS="~amd64 ~x86"
  13. SLOT="0"
  14. IUSE=""
  15. src_unpack() {
  16. unpack ${A}
  17. cd "${S}"
  18. unzip ${MY_P}.zip
  19. }
  20. src_install() {
  21. DOCS="${S}/README ${S}/LICENSE ${S}/doc/fonts/bera/bera.txt"
  22. # install sty and fonts
  23. cd "${S}/tex/latex/${MY_P}"
  24. latex-package_src_install
  25. cd "${S}/fonts/vf/public/${MY_P}"
  26. latex-package_src_install
  27. cd "${S}/fonts/tfm/public/${MY_P}"
  28. latex-package_src_install
  29. # install map
  30. cd "${S}"
  31. dodir ${TEXMF}/fonts/map/dvips/${MY_P}
  32. cp -pPR fonts/map/dvips/${MY_P}.map "${D}${TEXMF}/fonts/map/dvips/${MY_P}"
  33. latex-package_src_install
  34. }
  35. pkg_postinst() {
  36. latex-package_rehash
  37. updmap-sys --enable Map ${MY_P}.map
  38. }
  39. pkg_postrm() {
  40. updmap-sys --disable ${MY_P}.map
  41. }