rail-1.2_p1.ebuild 711 B

12345678910111213141516171819202122232425262728293031323334353637
  1. # Copyright 1999-2012 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI="4"
  4. inherit latex-package
  5. DESCRIPTION="Offers syntax/railroad diagrams"
  6. HOMEPAGE="http://www.ctan.org/tex-archive/support/rail/"
  7. SRC_URI="http://mirror.ctan.org/support/${PN}.zip
  8. -> ${P}.zip"
  9. LICENSE="LPPL-1.2"
  10. SLOT="0"
  11. KEYWORDS="~x86 ~amd64"
  12. IUSE=""
  13. RDEPEND="app-text/texlive"
  14. DEPEND="${RDEPEND}
  15. app-arch/unzip
  16. sys-devel/bison
  17. sys-devel/flex"
  18. S=${WORKDIR}/${PN}
  19. src_compile() {
  20. emake -j 1 || die "make failed"
  21. }
  22. src_install() {
  23. latex-package_src_doinstall sty doc
  24. dobin rail || die "Installing the rail tool failed"
  25. newman rail.man rail.1 || die "Installing the manpage failed"
  26. }