texlive-context-2012.ebuild 3.0 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263
  1. # Copyright 1999-2012 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI="4"
  4. TEXLIVE_MODULE_CONTENTS="context jmn lmextra context-account context-algorithmic context-bnf context-chromato context-construction-plan context-degrade context-filter context-fixme context-french context-fullpage context-games context-gantt context-gnuplot context-letter context-lettrine context-lilypond context-mathsets context-notes-zh-cn context-rst context-ruby context-simplefonts context-simpleslides context-typearea context-typescripts context-vim collection-context
  5. "
  6. TEXLIVE_MODULE_DOC_CONTENTS="context.doc context-account.doc context-bnf.doc context-chromato.doc context-construction-plan.doc context-degrade.doc context-filter.doc context-fixme.doc context-french.doc context-fullpage.doc context-games.doc context-gantt.doc context-gnuplot.doc context-letter.doc context-lettrine.doc context-lilypond.doc context-mathsets.doc context-notes-zh-cn.doc context-rst.doc context-ruby.doc context-simplefonts.doc context-simpleslides.doc context-typearea.doc context-typescripts.doc context-vim.doc "
  7. TEXLIVE_MODULE_SRC_CONTENTS="context-fixme.source "
  8. inherit texlive-module
  9. DESCRIPTION="TeXLive ConTeXt format"
  10. LICENSE="GPL-2 BSD GPL-1 public-domain TeX-other-free"
  11. SLOT="0"
  12. KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~x64-solaris ~x86-solaris"
  13. IUSE=""
  14. DEPEND=">=dev-texlive/texlive-basic-2012
  15. >=dev-texlive/texlive-latex-2010
  16. !<dev-texlive/texlive-latex-2010
  17. >=app-text/texlive-core-2010[xetex]
  18. >=dev-texlive/texlive-metapost-2010
  19. "
  20. RDEPEND="${DEPEND} dev-lang/ruby
  21. "
  22. TL_CONTEXT_UNIX_STUBS="context luatools mtxrun texexec texmfstart"
  23. TEXLIVE_MODULE_BINSCRIPTS="
  24. texmf-dist/scripts/context/ruby/ctxtools.rb
  25. texmf-dist/scripts/context/ruby/pstopdf.rb
  26. texmf-dist/scripts/context/ruby/rlxtools.rb
  27. "
  28. for i in ${TL_CONTEXT_UNIX_STUBS} ; do
  29. TEXLIVE_MODULE_BINSCRIPTS="${TEXLIVE_MODULE_BINSCRIPTS} texmf-dist/scripts/context/stubs/unix/$i"
  30. done
  31. # This small hack is needed in order to have a sane upgrade path:
  32. # the new TeX Live 2009 metapost produces this file but it is not recorded in
  33. # any package; when running fmtutil (like texmf-update does) this file will be
  34. # created and cause collisions.
  35. pkg_setup() {
  36. if [ -f "${ROOT}/var/lib/texmf/web2c/metapost/metafun.log" ]; then
  37. einfo "Removing ${ROOT}/var/lib/texmf/web2c/metapost/metafun.log"
  38. rm -f "${ROOT}/var/lib/texmf/web2c/metapost/metafun.log"
  39. fi
  40. }
  41. # These comes without +x bit set...
  42. src_prepare() {
  43. chmod +x texmf-dist/scripts/context/ruby/ctxtools.rb \
  44. texmf-dist/scripts/context/ruby/pstopdf.rb \
  45. texmf-dist/scripts/context/ruby/rlxtools.rb
  46. }
  47. TL_MODULE_INFORMATION="For using ConTeXt mkII simply use 'texexec' to generate
  48. your documents.
  49. If you plan to use mkIV and its 'context' command to generate your documents,
  50. you have to run 'luatools --generate' as normal user before first use.
  51. More information and advanced options on:
  52. http://wiki.contextgarden.net/TeX_Live_2011"