appdata-tools-0.1.7.ebuild 867 B

12345678910111213141516171819202122232425262728293031323334353637383940
  1. # Copyright 1999-2014 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=5
  4. inherit autotools
  5. MY_P="${PN/-/_}_${PV//./_}"
  6. DESCRIPTION="CLI designed to validate AppData descriptions for standards compliance and to the style guide"
  7. HOMEPAGE="https://github.com/hughsie/appdata-tools/"
  8. SRC_URI="https://github.com/hughsie/${PN}/archive/${MY_P}.tar.gz -> ${P}.tar.gz"
  9. LICENSE="GPL-2+"
  10. SLOT="0"
  11. KEYWORDS="~alpha amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc x86"
  12. IUSE="nls"
  13. RDEPEND=">=dev-libs/glib-2.14
  14. >=net-libs/libsoup-2.4
  15. >=x11-libs/gdk-pixbuf-2.0"
  16. DEPEND="${RDEPEND}
  17. app-text/docbook-xml-dtd:4.3
  18. dev-libs/libxslt
  19. nls? ( >=dev-util/intltool-0.35.0
  20. sys-devel/gettext )"
  21. S="${WORKDIR}/${PN}-${MY_P}"
  22. src_prepare() {
  23. eautoreconf
  24. }
  25. src_configure() {
  26. econf \
  27. $(use_enable nls) \
  28. --enable-man \
  29. --disable-schemas
  30. }