atomic-install-0.1.1.ebuild 610 B

1234567891011121314151617181920212223242526272829
  1. # Copyright 1999-2012 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=4
  4. inherit autotools-utils
  5. DESCRIPTION="A library and tool to atomically install sets of files"
  6. HOMEPAGE="https://github.com/mgorny/atomic-install/"
  7. SRC_URI="mirror://github/mgorny/${PN}/${P}.tar.bz2"
  8. LICENSE="BSD"
  9. SLOT="0"
  10. KEYWORDS="~amd64 ~x86"
  11. IUSE="doc static-libs xattr"
  12. RDEPEND="xattr? ( sys-apps/attr )"
  13. DEPEND="${RDEPEND}
  14. doc? ( >=dev-util/gtk-doc-1.18 )"
  15. src_configure() {
  16. myeconfargs=(
  17. $(use_enable doc gtk-doc)
  18. $(use_enable xattr libattr)
  19. )
  20. autotools-utils_src_configure
  21. }